How To Install WPScan on Ubuntu 14.04

r00t August 1, 2015

wpscan-logo

In this tutorial we will show you how to install WPScan in an Ubuntu 14.04. For those of you who didn’t know, WPScan is a black box WordPress vulnerability scanner. You can use it for problem location in case there are any vulnerable WordPress themes or WordPress plugins on your website.

This article assumes you have at least basic knowledge of linux, know how to use the shell, and most importantly, you host your site of your own VPS. The installation is quite simple. I will show you through the step by step installation WPScan in Ubuntu 14.04 server.

Install WPScan on Ubuntu 14.04

Step 1. First of all make sure that all packages are up to date.

Step 2. Install WPScan.

Install all required packages:

Now we need to clone the wpscan package from github:

Once the download is finished, you will need to navigate to the wpscan directory and install the required ruby gems using bundler:

To update WPScan, simply use the following command:

How to use WPScan

You can use WPScan through arguments. You can get a complete list of arguments by executing the following command:

Scan WordPress plugins:

Scan Vulnerable plugins:

Scan themes:

Scan vulnerable themes:

Scan user accounts:

Scan for timthumb installations:

Congratulation’s! You have successfully installed WPScan. Thanks for using this tutorial for installing WordPress vulnerability scanner in Ubuntu 14.04 system. For additional help or useful information, we recommend you to check the official WPScan web site.

VPS Manage Service Offer
If you don’t have time to do all of this stuff, or if this is not your area of expertise, we offer a service to do “VPS Manage Service Offer”, starting from $10 (Paypal payment). Please contact us to get a best deal!
Share on Google+0Share on Facebook4Tweet about this on TwitterShare on Tumblr0Share on StumbleUpon1Share on Reddit0Pin on Pinterest2
The Tags:

Leave a Comment